Forum Settings
       
Reply To Thread

enchanter pet/swordsFollow

#1 Apr 26 2017 at 9:16 AM Rating: Good
*
144 posts
I logged my chanter in for the first time in a long time and noticed there are a pair of flaming swords following me like a pet yet they are not my pet. they are causing problems moving. anyone know a fix for this? They obstruct my view as well like the old mounts used to.
#2 Apr 26 2017 at 10:27 AM Rating: Excellent
This is most likely a familiar. Look for a buff you have with familiar in the name.
____________________________
Allakhazam Developer

For real time update information on Allakhazam, follow me on Twitter!
https://twitter.com/gidono
#3 Apr 26 2017 at 6:51 PM Rating: Decent
10 posts
That happened to me as well. Every time I tried to run I shot like straight up as far as I could go. I solved it by letting a mob beat me to death and it was gone when I respawned at my bind and didn't show up after the rezz either. It hasn't happened since.

Edited, Apr 26th 2017 8:53pm by adeficium
#4 Apr 26 2017 at 7:12 PM Rating: Good
*
144 posts
I clicked off the familiar i had up but the swords are still there. They don't act like a familiar because they are right on top of me and move with me, not like a pet that is a bit away from me. Guess I'll try dying.

Edited, Apr 26th 2017 9:30pm by mtgdragon
#5 Apr 26 2017 at 7:30 PM Rating: Good
*
144 posts
Dying fixed it, thanks adeficium :)
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 88 All times are in CST
Anonymous Guests (88)